Shainal, yes I do require the version 8. I happen to submit a ticket already it has been about a week since I am yet to receive any response back from...