Announcement

Collapse
No announcement yet.

Rollback V11 is out... but have questions

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    On a Positive note for Rollback..
    - Baseline update works now (and gives back all missing space)
    - Cleanup images (remove / defragment) now updates the Free space)

    - The driver crash was also in 10.
    - The processor slowdown is new in 11.
    I do have many programs disabled during startup.
    What I can do is remove the Nvidia driver and see if it loads normally without errors.
    I am using Norton. idk if permanent Disable will work for now... Uninstalling I will loose all my custom settings.. so have to check.
    Other than that, there is nothing starting up during bootup.
    Last option is to try the PBR setting. to see if that makes a difference

    Comment


    • #17
      Ram Sarma and @Radkar

      I fixed the slow boot issue, and not sure if this is a Rollback Issue or Nvidia. I am leaning more towards Rollback, if you look at all the tests I did.


      These 2 versions of the Drivers seems to be causing the screen crashing. Version 398.36 and 382.33
      After uninstalling them, I let Windows 10 install the drivers, which is version 382.53.
      382.53 doesn't crash with Rollback RX 11 installed.

      NOW.... when I uninstall Rollback, then ALL drivers are working fine. including the 2 failed ones.
      Once Rollback is getting installed, then those 2 will fail, except the 382.53
      So, I am leaning towards an issue with that in V10.7 and V11,0

      Also, fastboot works with that driver.
      With the 398.36 / Fastboot enabled and Rollback installed result in a blank screen, and PC shuts down.
      With the 398.36 / Fastboot enabled the PC will boot up

      So I am suspecting that Rollback is causing a conflict with the newer version of the Video Driver. since the Never version is updated for CUDA and GPU for Graphics programs,
      I think this should be looked into. Don't think you want customers to default back to OLD drivers (about 1 - 1 1/2 years old)

      I'll create a support ticket again, but afraid that it will be blown off again, since they always blame it on my system, while it's clearly not.. and the Tests proof it.

      ticket #IWQ-549-13828
      So I hope that after 5 years of "complaining" about this with other versions, it will be looked into it more.

      For the "Display driver nvlddmkm stopped responding and has successfully recovered" problem..
      Then is stops it takes about 30-60 seconds, which explains the SLOW bootup.
      Last edited by mrdutchie; 07-07-2018, 06:16 AM.

      Comment


      • #18
        mrdutchie

        Yes, AFAIK the hibernate file is the file that fast boot is using, so it's the same....but apparently not the reason for slow boots.

        The first thing I can recommend is for you to have a full backup (image) of your system _without_ Rollback Rx installed, as this would cause problems after restoring (they are adressed in other topics and in Froggie's FAQ, just google it). So you have a nice clean image of your system you can restore if disaster strikes and you end up with an unbootable OS.

        Although you latest message here suggests that NVidia's drivers might have some compatibility issues with RollBack Rx, I am still suspicious about Norton. I haven't used it for at least a decade, but i assume it's still using functions of the Win kernel to block .exe files from doing their stuff, unless you explicitly allow it. To be sure it's not Norton, it would be best to completely uninstall it (maybe there's a function to export settings and re-import them after reinstalling it?), and then try RollBack rx.

        If that's not an option for you, temporarily configure Norton to "allow all", or whatever function it has to block the least possible amount. In addition to that, set "allow everything" for all files in RollBack Rx's installation folder.

        Do the same for "shdsync.exe" in your "Windows\system32" (or wherever the Installer has placed it) folder. This file is responsible for synching excluded files and folders after loading into different snapshots. And I've seen it slow down system startups considerably, even if nothing is blocking it.

        Then let us know how things are going.

        Comment


        • #19
          I didn't do anything with Norton, since I saw crashes from the Display driver, so I played with the drivers, while Rollback was installed.
          And the results are the test results in the post about you.
          it's working fine now with the drivers that Windows 10 came with for the Nvidia, and they are working fine.
          As soon as I update those drivers, then it's failing again for that 1 file "nvlddmkm"
          So I don't know how Rollback works with that.
          The only thing I have left is installing Rollback on the PBR instead of MBR, but since this is working now, I am leaving it for what it is, till I hear back from Tech Support.

          I still see some


          The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
          {D63B10C5-BB46-4990-A94F-E40B9D520160}
          and APPID
          {9CA88EE3-ACB7-47C8-AFC4-AB702511C276}
          to the user PERRY-LAPTOP\perry SID (S-1-5-21-3570557278-2179112837-2987519713-1001) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

          and

          The server {AB8902B4-09CA-4BB6-B78D-A8F59079A8D5} did not register with DCOM within the required timeout.

          Not sure what those are.

          But just saw there from an hour ago, so idk if those are related to Rollback.

          The speed of processor 1....8 in group 0 is being limited by system firmware. The processor has been in this reduced performance state for 2 seconds since the last report.

          it doesn't seem to hurt anything with what I do,
          Could be that the laptop came out of sleep, since I got back at that time, and opened up my screen.

          Comment


          • #20
            Seems like that CLSID is from Runtimebroker.exe and is controlling some of the apps from the MS Store etc. which cannot be disabled according to the site.
            so I guess those won't hurt..

            Then I don't think I have any issues at the moment with it..
            it seems to be running smoothly.

            1 think I forgot to mention.
            When it failed to boot, it did reset my Google Chrome browser with the plugins etc.. which I thought was interesting.
            but once logged in, I got them all back.

            Comment


            • #21
              Think I am screwed....
              Installed on PBR and installed the latest nvidia driver and it still crashed. So.... thought I'll do a rollback to my baseline.
              Its sitting here now for like 20 min sound synchronizing files and no change... I know when I will reboot it ain't going to boot anymore...

              It shouldn't take that long right? Don't see any activity on my keyboard either for ssd activity...

              Edit:
              Looks like my keyboard was locked up to so took the punch and rebooted the laptop.
              Everything came back up fine... pjeww..
              but the folders that we're created during the driver install, we're not deleted.. which was suppose to be.

              so idk, if restoring a baseline is different if you use PBR or MBR?
              (didn't try MBR) but 1st time i tried it locked up, so idk.

              I did make a copy of the Shield folder when the video driver was crashing, so if there is any data needed from that, then i have it
              Last edited by mrdutchie; 07-07-2018, 11:45 AM.

              Comment


              • #22
                Spoke too soon.... started getting lots of drive errors, so did another rollback.. and freezing up AGAIN....

                Hope I can recover from this one and uninstall rollback.. then I will try with the MBR instead.

                If that one fails too, then idk... lost my system due to rollback 11...

                Comment


                • #23
                  mrdutchie

                  This doesn't sound good

                  I hope you have all your data backed up, so you can restore your system quickly...I wouldn't rely on RollBack Rx working properly until you know for sure what conflict is causing the long pause during boot and the errors in Syslog.

                  I don't think MBR vs PBR would make much of a difference, although the MBR routine is certainly more tested by time.

                  What kind of drive errors are you getting?



                  Comment


                  • #24
                    Drive C NTSF errors in the windows event log.

                    But figured out the lockup.

                    I installed RX with MBR and did a rollback,
                    AGAIN.. Freezing during the rollback and drive corruption,.

                    So i DISABLED the Hibernate file AGAIN with powercfg /H off
                    so that my 27Gb file is gone.

                    Rebooted, made a snaphot
                    and did a rollback..
                    and guess what.. now it works again..
                    so bottom line the Hibernate file issue from 5 years ago is STILL NOT FIXED.

                    Guess I still can use RX 11, but with Hibernate disabled again.

                    The issue with the video driver stays, that will still cause a problem.

                    Comment


                    • #25
                      mrdutchie,

                      I don't think that Fast Startup (or fastboot) is the same as Hibernate, although both appear to involve a registry file called Hiberboot. Whether or not Hibernate is disabled, fast startup could still be either enabled or disabled. And my experience is that Rollback Rx doesn't work unless fast startup is disabled. Here is a link to a site that tells you how to do it: http://mywindowshub.com/how-to-turn-...in-windows-10/

                      Comment


                      • #26
                        it looks like Fastboot is enabled, but sure doesn't look like it.
                        The hibernate file is the one that makes it bootup quickly for me at least, and make my system work with Rollback. if the hibernate file is there, then everything fails

                        Also, it's greyed out, and taken over by another program. ( can can change the power setting, and then i can uncheck it) but later on it's checked again.
                        idk if Rollback is taken over the power plan..
                        Last edited by mrdutchie; 07-09-2018, 06:25 AM.

                        Comment


                        • #27
                          Hi mrdutchie. Allow me to explain when Fast Boot works.

                          Fast Boot only works if you SHUTDOWN your system. When you turn it on, it will Fast Boot (according to MS). If however you RESTART your system, then a FULL boot occurs (at every restart without fail). I think this is what you are doing and why it "sure doesn't look like it."

                          Now, my experience also caused corrupted snapshots (always after a shutdown) when Fast Boot was enabled. So, firstly, Fast Boot must be disable for RB to work without corrupting your snapshots. Sounds like this has already happened so i would strongly recommend restoring a backup image and starting again.

                          After you restore and with a corruption free system your must now disable Fast Boot. Follow the directions on the link provided by bdolotin (make sure you have enable the hybernation file first or you wont see the Fast boot setting).

                          Once Fast Boot is UNTICKED. Restart your system. Now check again to see if Fast Boot is still UNTICKED (it should be). Now install RB and check that the Fast Boot is still unticked (again, it should be unticked). Now test RB and there should no longer be any corrupted snapshots.

                          If corruption still occurs then look to see if Fast Boot has somehow renabled itself (which would indeed be bizzar). I know that with most major updates to the OS Fast Boot is renabled by MS so be aware of this and untick it again immediately. I always....always uninstall RB before any major OS update for this reason. Only after I've disable Fast Boot will I reinstall RB.

                          Thats all i have. I hope this has helped clear things up and resolves the corruption issue for you. Good Luck

                          Comment


                          • #28
                            Thanks, so what does the hibernate file do then? cause it's working fine, If I disable that one.

                            Comment


                            • #29
                              Thanks carfal for clarifying the details of Fast Boot...I didn't know the it was only activate after a shutdown, when enabled.

                              mrdutchie

                              The hibernate file is the "snapshot" of the system state before shutdown. It has the contents of RAM written into it (and probably more stuff), to restore the system to the state before it was shut down.

                              If fast boot is disabled, there should be no hibernate file on the disk.

                              Apparently having it enabled is still not supported by RollBack Rx...as carfal said, it seems like the system is in an inconsistent state when you have Fast Boot active with RollBack installed.

                              That's potentially dangerous for data integrity (NTFS does catch logical errors in the MFT, but not the contents of files ).

                              So, it's best to restore a clean Image of your system right now, if you want to be on the safe side. I certainly wouldn't trust the integrity of any files saved and/or modified during your experimenting with RollBack with Fast Boot enabled.

                              Btw, do you have some files or folders listed in your exclusion list in RollBack Rx?

                              Comment


                              • #30
                                All I have set to keep the same is My Documents and Desktop.

                                Guess where I have a hard time with it, that there is NOWHERE mention of it in the manual or anywhere else, besides me opening tickets
                                and complaining that RX is crashing on it.
                                And the Answer i got back is "Well, then just disable it"

                                What kind of answer is that from Support.

                                Hence, those people who said the same thing every time, and the promise that it was all going to be fixed, or no longer working for them.
                                So I am like in a circle repeating the same thing over and over.

                                I cannot imagine that I am the only one who is running into this issue..
                                unless all their customers are gone. :/
                                Last edited by mrdutchie; 07-09-2018, 11:56 AM.

                                Comment

                                Working...
                                X