Announcement

Collapse
No announcement yet.

Space eating bug in Rollback

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Space eating bug in Rollback

    It may be strange to write in a translator. Please understand.



    http://community.horizondatasys.com/...ug-in-rollback

    This is the same situation.

    I do not know why.
    I'm not creating a snapshot with the scheduler.

    Even if you empty the trash
    Space does not increase.

    At least I hope the space will increase when I reboot.
    Please tell me how.


    My computer specs

    I5-2500k
    Samsung ssd 120gb 750evo
    Windows Ultimate 64bit
    I have Rollback installed for about 3 months, and my HD space went from 140 Gb free to 22 Gb free. There is only 1 snapshot and the Baseline. I did a
    Last edited by mamamamama; 03-24-2017, 11:24 PM.

  • #2
    I had the same problem.
    My Drive C almost Filled Up!!
    I used WinDirStat and noticed there was an <Unknown> Dir which was increasing everyday.
    I uninstalled and then reinstalled Rollback.
    Suddenly, my <Free Space> went to 50Gb.The <Unknown> Dir was virtually empty.
    I had set Rollback to keep only the last 7 Days Snapshots.
    So, for the new few days, my <Free Space> decreased, and my <Unknown> Dir increased.
    But, after 7 days (which I had set for Rollback to keep Snapshots), I expected my <Free Space> to 'stabilize'.
    It Didnt!!
    My <Free Space> kept decreasing about 1-2GB per day and <Unknown> was increasing about the same amount.
    So, in desperation, after trying all sorts of things, I went to Advanced Settings in Rollback and 'unchecked' the Defrag snaphots options.
    Guess What!!
    My <Free Space> has now 'stabilised' and <Unknown> Dir is keeping 'about the same'.
    M**** of The Story???
    DO NOT DEFRAG A SSD DRIVE - Even in Rollback.
    So for people to 'regain' their 'Lost Free Space' on an SSD -
    1. Uninstall then Reinstall Rollback.
    2. Go To 'Tools & Settings>Settings>Advance Settings' and 'Uncheck' the Defrag snapshots Options.
    3. Re-Boot your Computer.
    I hope this helps,
    Peeter.


    Comment


    • #3
      Pparbo, Does this mean that releasing a snapshot Defragmentation option in the Advanced Settings?
      But Snapshots must be defragmented I think that free space is restored.

      Comment


      • #4
        To get all your Free Space back on a SSD you have to do what I have said.
        The 'Defrag' snapshots Options must be 'disabled'.
        Yes, I know that it sounds wrong. But if you are using a SSD, De-Fragging will not increase your Free Space.
        On an SSD, De-Fragging will do absolutely 'nothing'. except 'reoganise' fragmented Files within the same space that they already occupied.
        It will NOT give you extra Free Space!!
        On a 'Normal' Hard Disk Yes!!
        And that is the problem that you and I have had - Bit by Bit the Drive becomes 'fuller and fuller' and deleting anything makes 'no difference'.
        So, below I show how I have set my settings in Rollback.
        pic2.jpg
        I have 'unchecked' the Options under 'Defrag snapshots at the subsystem during the next bootup'..
        This was after I Uninstalled and Reinstalled Rollback.
        You must Uninstall and Reinstall Rollback to get all your Free Space back.


        Comment


        • #5
          Originally posted by pparbo View Post
          My <Free Space> kept decreasing about 1-2GB per day and <Unknown> was increasing about the same amount.
          So, in desperation, after trying all sorts of things, I went to Advanced Settings in Rollback and 'unchecked' the Defrag snaphots options.
          Guess What!!
          My <Free Space> has now 'stabilised' and <Unknown> Dir is keeping 'about the same'.
          Hi pparbo. Firstly, disabling the above mentioned setting only stops the defrag at boot time. RB has a "hard wired" defrag schedule internally (lucky for you) because attempting to completely stop RB's defrag is a bad idea (and advice).

          The defrag function in RB does not work like the defrag in Windows. The RB defrag serves as a means of RB consolidating and organizing its Snapshot database more efficiently and is vital to its proper functionality. What this means is that without this, RB will have no way of knowing how to release unused space from deleted files.

          When a file is deleted or changed by you or any other process, RB holds the space of that deleted/changed file until a RB defrag occurs. At this time, the deleted/changed file is checked to see if it exists in any other snapshot. If even one snapshot contains this file, the space is not released for obvious reasons. Multiply this by thousands of files a second and you can see why snapshots can grow to large sizes quickly. The key to managing the snapshot sizes is to be aware of large files that are created by you and to clean out your temporary files BEFORE taking a snapshot. CCleaner is what I recommend ( do not use the wipe hard disk function in CCleaner as this will fill your HD up completely ).

          Lastly, I think the solution to your problem is in finding out what process is manipulating the <Unknown> DIR. It is most certainly not RB. RB does not create any files or directories as part of its functions. It simply redirects all files changes and keeps track using a hidden table (no this is not the <Unknown> DIR).

          Goodluck

          Comment


          • #6
            OK, I understand You but Please Explain this to me.
            Why, after uninstalling RB, suddenly 70GB of Free Space appears??
            Running my System for a week after uninstalling RB, everything seems to be stable in Free Space.
            Then I reinstalled RB.
            Sure, I expected to lose Free Space because of the Base Snapshot, then for the next 7 I have set for it to keep.
            The Base Snapshot took about 10GB and the 7 Snaphots took about 1GB each.
            Then why after 7 days does my Free Space keep decreasing, and if left, will eventually fill up my Free Space??
            If I uninstall RB, then suddenly my Free Space comes back again.
            I reinstall RB with the Defrag options set off, and after 7 days everything is stable again.
            Yes I use CCleaner - have since the day it was released - it 'cleans up' not only the Windows Software Distribution/Downloads DIR but Temp Files - I run it about 2 times a day.
            As for Temp files, (Windows, Firefox, Thunderbird) I have re-directed them to a RamDisk - therefore they have nothing to do with my Drive C and are deleted everytime I re-boot.
            My Snapshots are set for 'First Boot of the Day' and are usually about 1GB in size.
            Why I used WinDirStat was because I could get a report of what was in drive C.
            I used to print this out and compare this to what was showing the next day.
            All there was was a Decrease in <Free Space" and an increase in <Unknown>.
            But this only happened with RB installed - without RB installed there was very little difference day-to-day.
            Yes I know deleting files does not increase Free Space because RB keeps track of things that have happened.
            But I am 'baffled' what has been happening.
            I NEVER had this problem when I had a 'normal' HDD.
            But now, I have seemed to have found a solution for my SSD - Everything seems to be FINE now - even though you may disagree with my solution.
            And, as I have stated before, I 'Love' RB, it has 'saved my bacon' many times in the past, and now Things (for me) seem to be working OK.

            Comment


            • #7
              OK, there does seem to be something amiss here.

              I've been using an SSD for about 3 yrs now and I can honestly say that I haven't had cause to look at what was going on with free space. My SSD is a Samsung 840 pro 240GB. My OS takes up about 68Gb and my snapshot tree can grow upwards of 40-50 snapshots before doing the usual maintenance of uninstalling, running Trim command and then reinstalling RB.For me, this has guaranteed me trouble free usage of RB. The snapshot sizes vary from small to some large (up to 5gb).

              Unfortunately my driving job takes me away from my PC these days so I usually am on for short times on the weekend. I'm going to keep and eye on my free space whenever I get on next to see if anything unusual is happening but I suspect I wont find anything.

              Sorry I cant help much but if I were you I would try submitting a support ticket and see what happens. I know that every now and then someone reports this space eating bug to HDS but it seems to be illusive. Very frustrating for people like you with this issue.

              Comment


              • #8
                You got me curious so I made a little time to look at how my free space looks.

                I installed windirstat and it looks like a nice little program. When I click on C: drive and select properties I can see that the same used and free space is displayed as in Windows Explorer properties. No surprises here as I expected this to be the case. Drive C free space WE.jpg




                Below is what RB reports as used and free

                Drive C free space RB.jpg


                This also matches. Now below is my current snapshot tree

                Rollback Snapshot History2.jpg



                If we add up all the snapshots after "installation" it comes to 5.97GB. If we now deduct the Installation snapshot of 68.1 from the reported 73.9 used space we get 5.8GB.

                So far my used and unused free space are agreeing except for the 170mb discrepancy which for me is neither here nor there. Having said that, I will be keeping an eye to see if this slowly increases.

                Its also worth noting that I have only drive C: protected and should make it easier to keep an eye on things. Multiple protected drives would of coarse be trickier for those of you following this thread.

                I'll endeavor to report again ASAP but no promises. You may have to wait till next weekend.
                Last edited by carfal; 04-02-2017, 06:48 PM.

                Comment


                • #9
                  All I can say is what happened to me was 'REALLY WEIRD'.
                  I hope I didn't frighten any new people to using RB.
                  For some reason, the way I have setup RB on my system is working GREAT now.
                  My Free Space varies between 62-64GB - Exactly as it should!
                  As for a 'Ticket', what should I say??
                  My RB was 'not working' but ,now suddenly, it is OK just because I have used settings that everyone else tells me that should make 'no difference'??
                  Believe Me, I have been on the 'other side of the coin'.
                  I have been in IT since 1979. I have worked in Software, Hardware, Customer Support and Technical Support.
                  This is the only problem that I have been 'Completely Baffled' by.
                  But my, maybe Unorthodox, solution seems to have worked. - For Me anyway.
                  Maybe the 'Techos' at RB may be able to explain to me what has happened - or maybe not.
                  So I will 'Wimp' out (From saying anymore about this) because, for me, everything is working OK for me.
                  But I will re-visit this Forum from Time-to-Time to see if anyone has any New Info.

                  Comment

                  Working...
                  X