Announcement

Collapse
No announcement yet.

Goodbye.. I give up.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Goodbye.. I give up.

    ok, I give up.

    This is really the poorest Customer Service I've ever seen.
    Promises about a Developer contacting me for the last couple of months/ a year.
    several attempts updating the ticket #ECG-818-45106, and yet no response.
    No Answer about questions I asked.
    No Nothing..
    Guess this company really doesn't care about service.

    Over a year and nobody from support isn't coming up with a solution.

  • #2
    mrdutchie,

    First off, I understand the frustration of not getting a software to install and run as intended. With the issues you've faced with trying to run RollBack Rx on your system, it can get tiresome trying to figure out what's wrong and fix it. I sincerely apologize for that stress.

    I know your ticket was made last April, and over the course of these past months you have been in direct contact with our development team over your specific build with them working and providing you with new builds just for your PC. Those builds didn't end up permanently fixing your issues, but the devteam spared as much time as they could on your matter while still tending to other projects.

    Now, the reason these things can take so long with a home user such as yourself is that your case is very specific to you, and the development team can only work on so many projects at once. We've had some pretty big things in the works now since the end of October (Drive Cloner Rx 6.0, an unannounced project coming soon, and prep-work for Windows 10). So, our resources have been fairly limited.

    Having said that, I am sorry about the recent responses I see here on your ticket. They haven't been explanatory and I can see why without any updated information coming your way it can reach a boiling point such as this.

    If you would like me to close down your matter now, let me know and I will close the ticket.

    Either way, thank you for your time.

    Comment


    • #3
      Might as well close it, since I am waiting since Oct. for a Dev to contact me. and kept promised "few days" "within a week" etc.. it's 4 months later again..
      And esp.. that nobody answers me what the max memory limit is... and other users even have more memory, and no problems.
      Don't get me wrong... it was working great with Windows 7. But Windows 8 is a big no no for me.
      if I think it finally works, then 2 days later it crashed the whole HD , and lost everything.. and the boot recovery isn't working at all.

      Comment


      • #4
        James responded to my ticket as well.. guess I will wait 1 more time to see if a Dev wakes up, and response to me..
        if not, then close the ticket by the end of the month!

        Comment


        • #5
          mrdutchie,

          First off, thank you very much for your patience and understanding through this long period of testing and troubleshooting as the development team has tried to get your PC running smoothly with our software.

          Unfortunately, at this point in time I'm told we are unable to get RollBack Rx running with your specific PC configuration. The development team has said that from the log files and testing that it has to do with a combination of the specific file system you have, the number of harddrives on site, the memory being used and how your RAM is interacting with your BIOS. Without RollBack Rx that is no problem, but the configuration of the software at this point in time is incompatible with your build. We have tried to address these in several test builds supplied for you, but as you know, there has been no success.

          At this point we do recommend you uninstall RollBack Rx, as the team cannot get your specific build to be compatible with RollBack Rx v10.2. This may change for future versions, but as of right now that is not the case.

          Thank you for all of your time working with the devteam.

          Comment


          • #6
            ok,
            it's just 2 drives 500 Gb and a 1 Tb drive. and the file system is what everyone else has with Windows 8.1
            I don't have rollback installed for a long time and using Time machine... which works perfect for me... not a single crash..

            Comment

            Working...
            X